If you have tested a script which works fine within a standard html development file, but for some reason it isn't working in Wordpress then you probably have a compatibility error. Actually the fix is pretty easy... simply wrap / start you code with a jQuery noConflict Wrapper

We prefer this approach over adding 'jQuery' in the place of every '$' as it enables you to cut and past a code and only change the first line in the document ready function. Otherwise it's tedious and easy to miss all the '$' within  larger scripts.Note that many scripts will not run in Wordpress without document ready.