WordPress 3.5 problems with jQuery

Glenn Glenn's Blog 1 Comment

If you are experiencing problems with your WordPress site even though you haven’t changed anything then your issue could be a little known jQuery compatibility issue. The latest jQuery update ver 1.9.0 has a number of conflicts with WordPress 3.5 and this could throw your WordPress theme out of sync. We suggest that instead of using the latest version (say from the Google repository) that you revert to an earlier stable version(s) such as:-


https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js

You can find all the jQuery Google Repository versions here:-

https://developers.google.com/speed/libraries/devguide?hl=fr#jquery

You’ll find that this magically springs your site back into action. Hopefully the WordPress and jQuery teams will get together to get these inconsistencies ironed out asap!

About the Author
Wordpress 3.5 problems with jQuery WordPress 3.5 problems with jQuery 0da77002febbfe28d15144a57bbcc2c9 s 180 d mm r g

Glenn

A highly experienced WordPress Web Developer, Front-end and Back-end Developer & New Media Specialist with extensive knowledge of a wide spectrum of technologies in the Development and Creative Industries built up over a number of years.

Comments 1

  1. Post
    Author

    This problem is not just limited to WordPress. I’ve since found that the ‘latest’ jQuery has conflicts with other jQery plugins, notably jQuery Cycle. I advise going back to 1.8.3 if you’ve been using 1.9+ and elements on your page have stopped working.

Leave a Reply

Your email address will not be published. Required fields are marked *